diff mbox

[FFmpeg-devel] lavd/sdl2: add sdl alias

Message ID 20160925122856.952-1-josh@itanimul.li
State Superseded
Headers show

Commit Message

Josh Dekker Sept. 25, 2016, 12:28 p.m. UTC
Signed-off-by: Josh de Kock <josh@itanimul.li>
---

 The --enable-sdl2 option is not being renamed because it's a fairly
 big change and sdl2 is incompatible with sdl.

 libavdevice/sdl2.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Carl Eugen Hoyos Sept. 25, 2016, 12:45 p.m. UTC | #1
2016-09-25 14:28 GMT+02:00 Josh de Kock <josh@itanimul.li>:
> Signed-off-by: Josh de Kock <josh@itanimul.li>
> ---
>
>  The --enable-sdl2 option is not being renamed because it's a fairly
>  big change and sdl2 is incompatible with sdl.

How is (old) sdl in FFmpeg incompatible with the new sdl2 in FFmpeg?

Please rename it.

Patch ok, Carl Eugen
Josh Dekker Sept. 25, 2016, 12:51 p.m. UTC | #2
On 25/09/2016 13:45, Carl Eugen Hoyos wrote:
> 2016-09-25 14:28 GMT+02:00 Josh de Kock <josh@itanimul.li>:
>> Signed-off-by: Josh de Kock <josh@itanimul.li>
>> ---
>>
>>  The --enable-sdl2 option is not being renamed because it's a fairly
>>  big change and sdl2 is incompatible with sdl.
>
> How is (old) sdl in FFmpeg incompatible with the new sdl2 in FFmpeg?
>
> Please rename it.

Do you have a way to rename the option but not the device? Unless you're
suggesting renaming the whole device, and then I'd like to know a way to 
have the check_pkg_config work with a different library name to what it 
searches for.

--
Josh
Carl Eugen Hoyos Sept. 25, 2016, 12:57 p.m. UTC | #3
2016-09-25 14:51 GMT+02:00 Josh de Kock <josh@itanimul.li>:
> On 25/09/2016 13:45, Carl Eugen Hoyos wrote:
>>
>> 2016-09-25 14:28 GMT+02:00 Josh de Kock <josh@itanimul.li>:
>>>
>>> Signed-off-by: Josh de Kock <josh@itanimul.li>
>>> ---
>>>
>>>  The --enable-sdl2 option is not being renamed because it's a fairly
>>>  big change and sdl2 is incompatible with sdl.
>>
>>
>> How is (old) sdl in FFmpeg incompatible with the new sdl2 in FFmpeg?
>>
>> Please rename it.
>
> Do you have a way to rename the option but not the device?

I don't understand this question:
How is the name of a configure option disabling an external library
related to the name of a device in libavdevice?

> Unless you're suggesting renaming the whole device, and then
> I'd like to know a way to have the check_pkg_config work with a
> different library name to what it searches for.

There is an option --disable-foo that you removed and instead
you added a new optoin --disable-foo2. Please rename
--disable-foo2 to --disable-foo.

Carl Eugen
Josh Dekker Sept. 25, 2016, 12:59 p.m. UTC | #4
On 25/09/2016 13:57, Carl Eugen Hoyos wrote:
> 2016-09-25 14:51 GMT+02:00 Josh de Kock <josh@itanimul.li>:
>> On 25/09/2016 13:45, Carl Eugen Hoyos wrote:
>>>
>>> 2016-09-25 14:28 GMT+02:00 Josh de Kock <josh@itanimul.li>:
>>>>
>>>> Signed-off-by: Josh de Kock <josh@itanimul.li>
>>>> ---
>>>>
>>>>  The --enable-sdl2 option is not being renamed because it's a fairly
>>>>  big change and sdl2 is incompatible with sdl.
>>>
>>>
>>> How is (old) sdl in FFmpeg incompatible with the new sdl2 in FFmpeg?
>>>
>>> Please rename it.
>>
>> Do you have a way to rename the option but not the device?
>
> I don't understand this question:
> How is the name of a configure option disabling an external library
> related to the name of a device in libavdevice?
Sorry, I meant the external lib, not the device.

>> Unless you're suggesting renaming the whole device, and then
>> I'd like to know a way to have the check_pkg_config work with a
>> different library name to what it searches for.
>
> There is an option --disable-foo that you removed and instead
> you added a new optoin --disable-foo2. Please rename
> --disable-foo2 to --disable-foo.
>
Yes, I'm saying I don't know how to achieve this without renaming the 
ext lib name (which obviously can't change).

--
Josh
diff mbox

Patch

diff --git a/libavdevice/sdl2.c b/libavdevice/sdl2.c
index 217ccc0..5d9e91e 100644
--- a/libavdevice/sdl2.c
+++ b/libavdevice/sdl2.c
@@ -352,7 +352,7 @@  static const AVClass sdl2_class = {
 };
 
 AVOutputFormat ff_sdl2_muxer = {
-    .name           = "sdl2",
+    .name           = "sdl,sdl2",
     .long_name      = NULL_IF_CONFIG_SMALL("SDL2 output device"),
     .priv_data_size = sizeof(SDLContext),
     .audio_codec    = AV_CODEC_ID_NONE,