diff mbox

[FFmpeg-devel] avfilter: rename scale.c,h to scale_eval

Message ID 8d5f2bde-1477-2082-b093-d9e5cf4d6623@gyani.pro
State Accepted
Headers show

Commit Message

Gyan Doshi Dec. 8, 2019, 11:17 a.m. UTC
Makes commit msgs less ambiguous.

Regards,
Gyan
From 331496c1746dfe66a893a6fde1b9cfacca100667 Mon Sep 17 00:00:00 2001
From: Gyan Doshi <ffmpeg@gyani.pro>
Date: Sun, 8 Dec 2019 16:42:36 +0530
Subject: [PATCH] avfilter: rename scale.c,h to scale_eval

scale.c is too generic; scale_eval is more representative
---
 libavfilter/Makefile                  | 10 +++++-----
 libavfilter/{scale.c => scale_eval.c} |  2 +-
 libavfilter/{scale.h => scale_eval.h} |  0
 libavfilter/vf_scale.c                |  2 +-
 libavfilter/vf_scale_cuda.c           |  2 +-
 libavfilter/vf_scale_npp.c            |  2 +-
 libavfilter/vf_scale_vaapi.c          |  2 +-
 7 files changed, 10 insertions(+), 10 deletions(-)
 rename libavfilter/{scale.c => scale_eval.c} (99%)
 rename libavfilter/{scale.h => scale_eval.h} (100%)

Comments

Gyan Doshi Dec. 9, 2019, 1:57 p.m. UTC | #1
On 08-12-2019 04:47 pm, Gyan wrote:
> Makes commit msgs less ambiguous.

Plan to push tomorrow.

Gyan
Michael Niedermayer Dec. 9, 2019, 9:42 p.m. UTC | #2
On Sun, Dec 08, 2019 at 04:47:17PM +0530, Gyan wrote:
> Makes commit msgs less ambiguous.
> 
> Regards,
> Gyan

>  Makefile         |   10 +++++-----
>  scale_eval.c     |    2 +-
>  vf_scale.c       |    2 +-
>  vf_scale_cuda.c  |    2 +-
>  vf_scale_npp.c   |    2 +-
>  vf_scale_vaapi.c |    2 +-
>  6 files changed, 10 insertions(+), 10 deletions(-)
> 45f5881be8abef7f4e7507cf8e491bb29455cb5e  0001-avfilter-rename-scale.c-h-to-scale_eval.patch
> From 331496c1746dfe66a893a6fde1b9cfacca100667 Mon Sep 17 00:00:00 2001
> From: Gyan Doshi <ffmpeg@gyani.pro>
> Date: Sun, 8 Dec 2019 16:42:36 +0530
> Subject: [PATCH] avfilter: rename scale.c,h to scale_eval
> 
> scale.c is too generic; scale_eval is more representative
> ---
>  libavfilter/Makefile                  | 10 +++++-----
>  libavfilter/{scale.c => scale_eval.c} |  2 +-
>  libavfilter/{scale.h => scale_eval.h} |  0
>  libavfilter/vf_scale.c                |  2 +-
>  libavfilter/vf_scale_cuda.c           |  2 +-
>  libavfilter/vf_scale_npp.c            |  2 +-
>  libavfilter/vf_scale_vaapi.c          |  2 +-
>  7 files changed, 10 insertions(+), 10 deletions(-)
>  rename libavfilter/{scale.c => scale_eval.c} (99%)
>  rename libavfilter/{scale.h => scale_eval.h} (100%)

AVFILTER_SCALE_H should be renamed too

thx

[...]
Gyan Doshi Dec. 10, 2019, 7:52 a.m. UTC | #3
On 10-12-2019 03:12 am, Michael Niedermayer wrote:
> On Sun, Dec 08, 2019 at 04:47:17PM +0530, Gyan wrote:
>> Makes commit msgs less ambiguous.
>>
>> Regards,
>> Gyan
>>   Makefile         |   10 +++++-----
>>   scale_eval.c     |    2 +-
>>   vf_scale.c       |    2 +-
>>   vf_scale_cuda.c  |    2 +-
>>   vf_scale_npp.c   |    2 +-
>>   vf_scale_vaapi.c |    2 +-
>>   6 files changed, 10 insertions(+), 10 deletions(-)
>> 45f5881be8abef7f4e7507cf8e491bb29455cb5e  0001-avfilter-rename-scale.c-h-to-scale_eval.patch
>>  From 331496c1746dfe66a893a6fde1b9cfacca100667 Mon Sep 17 00:00:00 2001
>> From: Gyan Doshi <ffmpeg@gyani.pro>
>> Date: Sun, 8 Dec 2019 16:42:36 +0530
>> Subject: [PATCH] avfilter: rename scale.c,h to scale_eval
>>
>> scale.c is too generic; scale_eval is more representative
>> ---
>>   libavfilter/Makefile                  | 10 +++++-----
>>   libavfilter/{scale.c => scale_eval.c} |  2 +-
>>   libavfilter/{scale.h => scale_eval.h} |  0
>>   libavfilter/vf_scale.c                |  2 +-
>>   libavfilter/vf_scale_cuda.c           |  2 +-
>>   libavfilter/vf_scale_npp.c            |  2 +-
>>   libavfilter/vf_scale_vaapi.c          |  2 +-
>>   7 files changed, 10 insertions(+), 10 deletions(-)
>>   rename libavfilter/{scale.c => scale_eval.c} (99%)
>>   rename libavfilter/{scale.h => scale_eval.h} (100%)
> AVFILTER_SCALE_H should be renamed too
Done and pushed as e73688eff43727eb79eb344a4def49540d463902

Thanks,
Gyan
diff mbox

Patch

diff --git a/libavfilter/Makefile b/libavfilter/Makefile
index 52f3616b2f..446c802b98 100644
--- a/libavfilter/Makefile
+++ b/libavfilter/Makefile
@@ -359,12 +359,12 @@  OBJS-$(CONFIG_ROBERTS_OPENCL_FILTER)         += vf_convolution_opencl.o opencl.o
                                                 opencl/convolution.o
 OBJS-$(CONFIG_ROTATE_FILTER)                 += vf_rotate.o
 OBJS-$(CONFIG_SAB_FILTER)                    += vf_sab.o
-OBJS-$(CONFIG_SCALE_FILTER)                  += vf_scale.o scale.o
-OBJS-$(CONFIG_SCALE_CUDA_FILTER)             += vf_scale_cuda.o vf_scale_cuda.ptx.o scale.o
-OBJS-$(CONFIG_SCALE_NPP_FILTER)              += vf_scale_npp.o scale.o
+OBJS-$(CONFIG_SCALE_FILTER)                  += vf_scale.o scale_eval.o
+OBJS-$(CONFIG_SCALE_CUDA_FILTER)             += vf_scale_cuda.o vf_scale_cuda.ptx.o scale_eval.o
+OBJS-$(CONFIG_SCALE_NPP_FILTER)              += vf_scale_npp.o scale_eval.o
 OBJS-$(CONFIG_SCALE_QSV_FILTER)              += vf_scale_qsv.o
-OBJS-$(CONFIG_SCALE_VAAPI_FILTER)            += vf_scale_vaapi.o scale.o vaapi_vpp.o
-OBJS-$(CONFIG_SCALE2REF_FILTER)              += vf_scale.o scale.o
+OBJS-$(CONFIG_SCALE_VAAPI_FILTER)            += vf_scale_vaapi.o scale_eval.o vaapi_vpp.o
+OBJS-$(CONFIG_SCALE2REF_FILTER)              += vf_scale.o scale_eval.o
 OBJS-$(CONFIG_SCROLL_FILTER)                 += vf_scroll.o
 OBJS-$(CONFIG_SELECT_FILTER)                 += f_select.o
 OBJS-$(CONFIG_SELECTIVECOLOR_FILTER)         += vf_selectivecolor.o
diff --git a/libavfilter/scale.c b/libavfilter/scale_eval.c
similarity index 99%
rename from libavfilter/scale.c
rename to libavfilter/scale_eval.c
index 4f00c5c72e..a3439a95e0 100644
--- a/libavfilter/scale.c
+++ b/libavfilter/scale_eval.c
@@ -19,7 +19,7 @@ 
  */
 
 #include <stdint.h>
-#include "scale.h"
+#include "scale_eval.h"
 #include "libavutil/eval.h"
 #include "libavutil/mathematics.h"
 #include "libavutil/pixdesc.h"
diff --git a/libavfilter/scale.h b/libavfilter/scale_eval.h
similarity index 100%
rename from libavfilter/scale.h
rename to libavfilter/scale_eval.h
diff --git a/libavfilter/vf_scale.c b/libavfilter/vf_scale.c
index b7f541be1f..8620d1c44e 100644
--- a/libavfilter/vf_scale.c
+++ b/libavfilter/vf_scale.c
@@ -29,7 +29,7 @@ 
 #include "avfilter.h"
 #include "formats.h"
 #include "internal.h"
-#include "scale.h"
+#include "scale_eval.h"
 #include "video.h"
 #include "libavutil/avstring.h"
 #include "libavutil/internal.h"
diff --git a/libavfilter/vf_scale_cuda.c b/libavfilter/vf_scale_cuda.c
index cca68dd835..1ffb73f831 100644
--- a/libavfilter/vf_scale_cuda.c
+++ b/libavfilter/vf_scale_cuda.c
@@ -35,7 +35,7 @@ 
 #include "avfilter.h"
 #include "formats.h"
 #include "internal.h"
-#include "scale.h"
+#include "scale_eval.h"
 #include "video.h"
 
 static const enum AVPixelFormat supported_formats[] = {
diff --git a/libavfilter/vf_scale_npp.c b/libavfilter/vf_scale_npp.c
index 09c3d51727..502ecfda94 100644
--- a/libavfilter/vf_scale_npp.c
+++ b/libavfilter/vf_scale_npp.c
@@ -37,7 +37,7 @@ 
 #include "avfilter.h"
 #include "formats.h"
 #include "internal.h"
-#include "scale.h"
+#include "scale_eval.h"
 #include "video.h"
 
 #define CHECK_CU(x) FF_CUDA_CHECK_DL(ctx, device_hwctx->internal->cuda_dl, x)
diff --git a/libavfilter/vf_scale_vaapi.c b/libavfilter/vf_scale_vaapi.c
index 88642cbe73..8298a013da 100644
--- a/libavfilter/vf_scale_vaapi.c
+++ b/libavfilter/vf_scale_vaapi.c
@@ -26,7 +26,7 @@ 
 #include "avfilter.h"
 #include "formats.h"
 #include "internal.h"
-#include "scale.h"
+#include "scale_eval.h"
 #include "video.h"
 #include "vaapi_vpp.h"