[FFmpeg-devel,1/2] libavcodec/libx264: do not define X264_API_IMPORTS

Submitted by anonymous.maarten@gmail.com on Sept. 3, 2018, 5:27 p.m.

Details

Message ID 20180903172714.22510-2-anonymous.maarten@gmail.com
State New
Headers show

Commit Message

anonymous.maarten@gmail.com Sept. 3, 2018, 5:27 p.m.
From: Anonymous Maarten <anonymous.maarten@gmail.com>

These defines should be passed by pkg-config.
---
 libavcodec/libx264.c | 4 ----
 1 file changed, 4 deletions(-)

Comments

Hendrik Leppkes Sept. 3, 2018, 6:01 p.m.
On Mon, Sep 3, 2018 at 7:27 PM <anonymous.maarten@gmail.com> wrote:
>
> From: Anonymous Maarten <anonymous.maarten@gmail.com>
>
> These defines should be passed by pkg-config.

Are they? Because if not, you should get that fixed upstream first
before these commits are acceptable and cause regressions.

- Hendrik

Patch hide | download patch | download mbox

diff --git a/libavcodec/libx264.c b/libavcodec/libx264.c
index 54e6703d73..b6f4c102c4 100644
--- a/libavcodec/libx264.c
+++ b/libavcodec/libx264.c
@@ -29,10 +29,6 @@ 
 #include "avcodec.h"
 #include "internal.h"
 
-#if defined(_MSC_VER)
-#define X264_API_IMPORTS 1
-#endif
-
 #include <x264.h>
 #include <float.h>
 #include <math.h>