[FFmpeg-devel,1/2] configure: update api version of libdavs2

Submitted by hwren on Nov. 17, 2018, 4:54 p.m.

Details

Message ID c88205a.4bbd.16722980cc9.Coremail.hwrenx@126.com
State New
Headers show

Commit Message

hwren Nov. 17, 2018, 4:54 p.m.
From: hwrenx <hwrenx@126.com> 

api version update.

detials could be found in davs2-git 
https://github.com/pkuvcl/davs2 

Signed-off-by: hwrenx <hwrenx@126.com> 
--- 
configure | 2 +- 
1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Carl Eugen Hoyos Nov. 17, 2018, 5:01 p.m.
2018-11-17 17:54 GMT+01:00, hwren <hwrenx@126.com>:
> From: hwrenx <hwrenx@126.com>
>
> api version update.
>
> detials could be found in davs2-git
> https://github.com/pkuvcl/davs2
>
> Signed-off-by: hwrenx <hwrenx@126.com>
> ---
> configure | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/configure b/configure
> index 9bc4cf3..d2159db 100755
> --- a/configure
> +++ b/configure
> @@ -6075,7 +6075,7 @@ enabled libcelt           && require libcelt
> celt/celt.h celt_decode -lcelt0 &&
> enabled libcaca           && require_pkg_config libcaca caca caca.h
> caca_create_canvas
> enabled libcodec2         && require libcodec2 codec2/codec2.h codec2_create
> -lcodec2
> enabled libdav1d          && require_pkg_config libdav1d "dav1d >= 0.0.1"
> "dav1d/dav1d.h" dav1d_version
> -enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.5.115"
> davs2.h davs2_decoder_open
> +enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.6.0"
> davs2.h davs2_decoder_open

Does this fix a regression in FFmpeg? If yes, please mention it in the
commit message.
(If not, what does this patch do?)

Carl Eugen
Michael Niedermayer Nov. 17, 2018, 6:45 p.m.
On Sun, Nov 18, 2018 at 12:54:09AM +0800, hwren wrote:
> From: hwrenx <hwrenx@126.com> 
> 
> api version update.
> 
> detials could be found in davs2-git 
> https://github.com/pkuvcl/davs2 
> 
> Signed-off-by: hwrenx <hwrenx@126.com> 
> --- 
> configure | 2 +- 
> 1 file changed, 1 insertion(+), 1 deletion(-) 
> 
> diff --git a/configure b/configure 
> index 9bc4cf3..d2159db 100755 
> --- a/configure 
> +++ b/configure 
> @@ -6075,7 +6075,7 @@ enabled libcelt           && require libcelt celt/celt.h celt_decode -lcelt0 && 
> enabled libcaca           && require_pkg_config libcaca caca caca.h caca_create_canvas 
> enabled libcodec2         && require libcodec2 codec2/codec2.h codec2_create -lcodec2 
> enabled libdav1d          && require_pkg_config libdav1d "dav1d >= 0.0.1" "dav1d/dav1d.h" dav1d_version 
> -enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.5.115" davs2.h davs2_decoder_open 
> +enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.6.0" davs2.h davs2_decoder_open 
> enabled libdc1394         && require_pkg_config libdc1394 libdc1394-2 dc1394/dc1394.h dc1394_new 

this patch is malformed and cannot be applied automatically

[...]
hwren Nov. 18, 2018, 7:26 a.m.
At 2018-11-18 01:01:36, "Carl Eugen Hoyos" <ceffmpeg@gmail.com> wrote:
>2018-11-17 17:54 GMT+01:00, hwren <hwrenx@126.com>:
>> From: hwrenx <hwrenx@126.com>
>>
>> api version update.
>>
>> detials could be found in davs2-git
>> https://github.com/pkuvcl/davs2
>>
>> Signed-off-by: hwrenx <hwrenx@126.com>
>> ---
>> configure | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/configure b/configure
>> index 9bc4cf3..d2159db 100755
>> --- a/configure
>> +++ b/configure
>> @@ -6075,7 +6075,7 @@ enabled libcelt           && require libcelt
>> celt/celt.h celt_decode -lcelt0 &&
>> enabled libcaca           && require_pkg_config libcaca caca caca.h
>> caca_create_canvas
>> enabled libcodec2         && require libcodec2 codec2/codec2.h codec2_create
>> -lcodec2
>> enabled libdav1d          && require_pkg_config libdav1d "dav1d >= 0.0.1"
>> "dav1d/dav1d.h" dav1d_version
>> -enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.5.115"
>> davs2.h davs2_decoder_open
>> +enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.6.0"
>> davs2.h davs2_decoder_open
>
>Does this fix a regression in FFmpeg? If yes, please mention it in the
>commit message.
>(If not, what does this patch do?)

I'm sorry for the missing message. New api enable avx option.
New patches would be submitted soon. Thanks.

>
>Carl Eugen
>_______________________________________________
>ffmpeg-devel mailing list
>ffmpeg-devel@ffmpeg.org
>http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
hwren Nov. 18, 2018, 7:37 a.m.
At 2018-11-18 02:45:23, "Michael Niedermayer" <michael@niedermayer.cc> wrote:
>On Sun, Nov 18, 2018 at 12:54:09AM +0800, hwren wrote:
>> From: hwrenx <hwrenx@126.com> 
>> 
>> api version update.
>> 
>> detials could be found in davs2-git 
>> https://github.com/pkuvcl/davs2 
>> 
>> Signed-off-by: hwrenx <hwrenx@126.com> 
>> --- 
>> configure | 2 +- 
>> 1 file changed, 1 insertion(+), 1 deletion(-) 
>> 
>> diff --git a/configure b/configure 
>> index 9bc4cf3..d2159db 100755 
>> --- a/configure 
>> +++ b/configure 
>> @@ -6075,7 +6075,7 @@ enabled libcelt           && require libcelt celt/celt.h celt_decode -lcelt0 && 
>> enabled libcaca           && require_pkg_config libcaca caca caca.h caca_create_canvas 
>> enabled libcodec2         && require libcodec2 codec2/codec2.h codec2_create -lcodec2 
>> enabled libdav1d          && require_pkg_config libdav1d "dav1d >= 0.0.1" "dav1d/dav1d.h" dav1d_version 
>> -enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.5.115" davs2.h davs2_decoder_open 
>> +enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.6.0" davs2.h davs2_decoder_open 
>> enabled libdc1394         && require_pkg_config libdc1394 libdc1394-2 dc1394/dc1394.h dc1394_new 
>
>this patch is malformed and cannot be applied automatically

I'm not sure what happened cause my patch-email generated by "git send-email" were identified as spams.
But it worked if I just  pasted the message into a new email.
Anyway, the new patches were submitted through another stmp server.

Thanks.

>
>[...]
>-- 
>Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
>
>When you are offended at any man's fault, turn to yourself and study your
>own failings. Then you will forget your anger. -- Epictetus

Patch hide | download patch | download mbox

diff --git a/configure b/configure 
index 9bc4cf3..d2159db 100755 
--- a/configure 
+++ b/configure 
@@ -6075,7 +6075,7 @@  enabled libcelt           && require libcelt celt/celt.h celt_decode -lcelt0 && 
enabled libcaca           && require_pkg_config libcaca caca caca.h caca_create_canvas 
enabled libcodec2         && require libcodec2 codec2/codec2.h codec2_create -lcodec2 
enabled libdav1d          && require_pkg_config libdav1d "dav1d >= 0.0.1" "dav1d/dav1d.h" dav1d_version 
-enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.5.115" davs2.h davs2_decoder_open 
+enabled libdavs2          && require_pkg_config libdavs2 "davs2 >= 1.6.0" davs2.h davs2_decoder_open 
enabled libdc1394         && require_pkg_config libdc1394 libdc1394-2 dc1394/dc1394.h dc1394_new 
enabled libdrm            && require_pkg_config libdrm libdrm xf86drm.h drmGetVersion 
enabled libfdk_aac        && { check_pkg_config libfdk_aac fdk-aac "fdk-aac/aacenc_lib.h" aacEncOpen ||