[FFmpeg-devel] configure: fix dependencies for mlp and truehd encoders

Submitted by Moritz Barsnick on Feb. 12, 2019, 4:51 p.m.

Details

Message ID 20190212165126.GC4634@sunshine.barsnick.net
State Accepted
Commit a84af760b809c4a2a6bc33c2f88f82dd9d1952bc
Headers show

Commit Message

Moritz Barsnick Feb. 12, 2019, 4:51 p.m.
Signed-off-by: Moritz Barsnick <barsnick@gmx.net>
---

Found with a minimal build using "--enable-encoder=truehd"

I reviewed other libavcodec sources makeing use of audio_frame_queue, and
their dependencies all seem to include this, but I didn't check which sub-
decoders are defined by these source files. (Like here: truehd_encoder is
provided by mlpenc.c.)

 configure | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Carl Eugen Hoyos Feb. 12, 2019, 9:54 p.m.
2019-02-12 17:51 GMT+01:00, Moritz Barsnick <barsnick@gmx.net>:
> Signed-off-by: Moritz Barsnick <barsnick@gmx.net>
> ---
>
> Found with a minimal build using "--enable-encoder=truehd"

Patch applied.

Thank you, Carl Eugen

Patch hide | download patch | download mbox

diff --git a/configure b/configure
index ac2d7ab402..bf40c1dcb9 100755
--- a/configure
+++ b/configure
@@ -2699,7 +2699,7 @@  mjpeg_decoder_select="blockdsp hpeldsp exif idctdsp jpegtables"
 mjpeg_encoder_select="jpegtables mpegvideoenc"
 mjpegb_decoder_select="mjpeg_decoder"
 mlp_decoder_select="mlp_parser"
-mlp_encoder_select="lpc"
+mlp_encoder_select="lpc audio_frame_queue"
 motionpixels_decoder_select="bswapdsp"
 mp1_decoder_select="mpegaudio"
 mp1float_decoder_select="mpegaudio"
@@ -2781,7 +2781,7 @@  thp_decoder_select="mjpeg_decoder"
 tiff_decoder_suggest="zlib lzma"
 tiff_encoder_suggest="zlib"
 truehd_decoder_select="mlp_parser"
-truehd_encoder_select="lpc"
+truehd_encoder_select="lpc audio_frame_queue"
 truemotion2_decoder_select="bswapdsp"
 truespeech_decoder_select="bswapdsp"
 tscc_decoder_deps="zlib"