diff mbox

[FFmpeg-devel,01/14] avutil/opt: add AV_OPT_FLAG_COMMAND_PARAM flag

Message ID 20191009101705.7072-1-onemda@gmail.com
State New
Headers show

Commit Message

Paul B Mahol Oct. 9, 2019, 10:16 a.m. UTC
Signed-off-by: Paul B Mahol <onemda@gmail.com>
---
 libavutil/opt.h | 1 +
 1 file changed, 1 insertion(+)

Comments

Michael Niedermayer Oct. 9, 2019, 5 p.m. UTC | #1
On Wed, Oct 09, 2019 at 12:16:52PM +0200, Paul B Mahol wrote:
> Signed-off-by: Paul B Mahol <onemda@gmail.com>
> ---
>  libavutil/opt.h | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/libavutil/opt.h b/libavutil/opt.h
> index 39f4a8dda0..693a170bcc 100644
> --- a/libavutil/opt.h
> +++ b/libavutil/opt.h
> @@ -288,6 +288,7 @@ typedef struct AVOption {
>   */
>  #define AV_OPT_FLAG_READONLY        128
>  #define AV_OPT_FLAG_BSF_PARAM       (1<<8) ///< a generic parameter which can be set by the user for bit stream filtering
> +#define AV_OPT_FLAG_COMMAND_PARAM   (1<<15) ///< a generic parameter which can be set by the user via commands with filtering
>  #define AV_OPT_FLAG_FILTERING_PARAM (1<<16) ///< a generic parameter which can be set by the user for filtering
>  #define AV_OPT_FLAG_DEPRECATED      (1<<17) ///< set if option is deprecated, users should refer to AVOption.help text for more information
>  //FIXME think about enc-audio, ... style flags

this looks good to me but iam not sure about the name
because what is a command parameter? (in the context of a libavutil AVOption)

What this really does is it marks AVOptions which 
can be changed at runtime (through commands) but if it wasnt done through 
commands but by other means i think this would also work
so maybe AV_OPT_FLAG_RUNTIME_PARAM or something like that would be a more
generic concept which could be usefull in other cases

Thanks

[...]
Paul B Mahol Oct. 9, 2019, 6:19 p.m. UTC | #2
On 10/9/19, Michael Niedermayer <michael@niedermayer.cc> wrote:
> On Wed, Oct 09, 2019 at 12:16:52PM +0200, Paul B Mahol wrote:
>> Signed-off-by: Paul B Mahol <onemda@gmail.com>
>> ---
>>  libavutil/opt.h | 1 +
>>  1 file changed, 1 insertion(+)
>>
>> diff --git a/libavutil/opt.h b/libavutil/opt.h
>> index 39f4a8dda0..693a170bcc 100644
>> --- a/libavutil/opt.h
>> +++ b/libavutil/opt.h
>> @@ -288,6 +288,7 @@ typedef struct AVOption {
>>   */
>>  #define AV_OPT_FLAG_READONLY        128
>>  #define AV_OPT_FLAG_BSF_PARAM       (1<<8) ///< a generic parameter which
>> can be set by the user for bit stream filtering
>> +#define AV_OPT_FLAG_COMMAND_PARAM   (1<<15) ///< a generic parameter
>> which can be set by the user via commands with filtering
>>  #define AV_OPT_FLAG_FILTERING_PARAM (1<<16) ///< a generic parameter
>> which can be set by the user for filtering
>>  #define AV_OPT_FLAG_DEPRECATED      (1<<17) ///< set if option is
>> deprecated, users should refer to AVOption.help text for more information
>>  //FIXME think about enc-audio, ... style flags
>
> this looks good to me but iam not sure about the name
> because what is a command parameter? (in the context of a libavutil
> AVOption)
>
> What this really does is it marks AVOptions which
> can be changed at runtime (through commands) but if it wasnt done through
> commands but by other means i think this would also work
> so maybe AV_OPT_FLAG_RUNTIME_PARAM or something like that would be a more
> generic concept which could be usefull in other cases
>

Agreed, will rename.

> Thanks
>
> [...]
>
> --
> Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
>
> it is not once nor twice but times without number that the same ideas make
> their appearance in the world. -- Aristotle
>
Nicolas George Oct. 10, 2019, 4:32 p.m. UTC | #3
Michael Niedermayer (12019-10-09):
> this looks good to me but iam not sure about the name
> because what is a command parameter? (in the context of a libavutil AVOption)
> 
> What this really does is it marks AVOptions which 
> can be changed at runtime (through commands) but if it wasnt done through 
> commands but by other means i think this would also work
> so maybe AV_OPT_FLAG_RUNTIME_PARAM or something like that would be a more
> generic concept which could be usefull in other cases

I agree this is a better name. I suspect user documentation is missing
too. I still intend to review the new series when times permit,
hopefully between Saturday and Monday.

Regards,
diff mbox

Patch

diff --git a/libavutil/opt.h b/libavutil/opt.h
index 39f4a8dda0..693a170bcc 100644
--- a/libavutil/opt.h
+++ b/libavutil/opt.h
@@ -288,6 +288,7 @@  typedef struct AVOption {
  */
 #define AV_OPT_FLAG_READONLY        128
 #define AV_OPT_FLAG_BSF_PARAM       (1<<8) ///< a generic parameter which can be set by the user for bit stream filtering
+#define AV_OPT_FLAG_COMMAND_PARAM   (1<<15) ///< a generic parameter which can be set by the user via commands with filtering
 #define AV_OPT_FLAG_FILTERING_PARAM (1<<16) ///< a generic parameter which can be set by the user for filtering
 #define AV_OPT_FLAG_DEPRECATED      (1<<17) ///< set if option is deprecated, users should refer to AVOption.help text for more information
 //FIXME think about enc-audio, ... style flags