[FFmpeg-devel] configure: require pkg-config for libvmaf

Submitted by Ashish Singh on Aug. 1, 2017, 3:14 p.m.

Details

Message ID 1501600458-9286-1-git-send-email-ashk43712@gmail.com
State New
Headers show

Commit Message

Ashish Singh Aug. 1, 2017, 3:14 p.m.
From: Ashish Singh <ashk43712@gmail.com>

This patch makes the libvmaf filter use pkg-config to detect
and link to libvmaf.

Signed-off-by: Ashish Singh <ashk43712@gmail.com>
---
 configure | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Ronald S. Bultje Aug. 30, 2017, 1:24 p.m.
Hi,

On Tue, Aug 1, 2017 at 11:14 AM, Ashish Pratap Singh <ashk43712@gmail.com>
wrote:

> From: Ashish Singh <ashk43712@gmail.com>
>
> This patch makes the libvmaf filter use pkg-config to detect
> and link to libvmaf.
>
> Signed-off-by: Ashish Singh <ashk43712@gmail.com>
> ---
>  configure | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>

Pushed.

Ronald

Patch hide | download patch | download mbox

diff --git a/configure b/configure
index 57694f3..aa8a785 100755
--- a/configure
+++ b/configure
@@ -5848,8 +5848,7 @@  enabled libtwolame        && require libtwolame twolame.h twolame_init -ltwolame
                                die "ERROR: libtwolame must be installed and version must be >= 0.3.10"; }
 enabled libv4l2           && require_pkg_config libv4l2 libv4l2.h v4l2_ioctl
 enabled libvidstab        && require_pkg_config "vidstab >= 0.98" vid.stab/libvidstab.h vsMotionDetectInit
-enabled libvmaf           && { check_lib libvmaf "libvmaf.h" "compute_vmaf" -lvmaf -lstdc++ -lpthread -lm ||
-                               die "ERROR: libvmaf must be installed"; }
+enabled libvmaf           && require_pkg_config libvmaf libvmaf.h compute_vmaf
 enabled libvo_amrwbenc    && require libvo_amrwbenc vo-amrwbenc/enc_if.h E_IF_init -lvo-amrwbenc
 enabled libvorbis         && require libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbisenc -lvorbis -logg