[FFmpeg-devel] configure: v4l2_m2m depends on pthreads

Submitted by Mark Thompson on Oct. 25, 2017, 1:32 p.m.

Details

Message ID 27e5b360-1210-d550-c8de-a761f8e9f326@jkqxz.net
State New
Headers show

Commit Message

Mark Thompson Oct. 25, 2017, 1:32 p.m.
Fixes build with --disable-pthreads.
---
 configure | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch hide | download patch | download mbox

diff --git a/configure b/configure
index c86e578..76523c8 100755
--- a/configure
+++ b/configure
@@ -2780,7 +2780,7 @@  omx_rpi_select="omx"
 qsvdec_select="qsv"
 qsvenc_select="qsv"
 vaapi_encode_deps="vaapi"
-v4l2_m2m_deps_any="linux_videodev2_h"
+v4l2_m2m_deps="linux_videodev2_h pthreads"
 
 hwupload_cuda_filter_deps="cuda"
 scale_npp_filter_deps="cuda libnpp"