[FFmpeg-devel,10/11] decklink: log Blackmagic SDK version compiled against

Submitted by Devin Heitmueller on Jan. 9, 2018, 1:16 a.m.

Details

Message ID 20180109011658.72370-11-dheitmueller@ltnglobal.com
State New
Headers show

Commit Message

Devin Heitmueller Jan. 9, 2018, 1:16 a.m.
Add a line to show the SDK version used in the build, if loglevel
is set to verbose.  This is simply to aid in debugging when
building against different SDKs.

Signed-off-by: Devin Heitmueller <dheitmueller@ltnglobal.com>
---
 libavdevice/decklink_common.cpp | 4 ++++
 1 file changed, 4 insertions(+)

Patch hide | download patch | download mbox

diff --git a/libavdevice/decklink_common.cpp b/libavdevice/decklink_common.cpp
index e7daa63..b033e63 100644
--- a/libavdevice/decklink_common.cpp
+++ b/libavdevice/decklink_common.cpp
@@ -448,6 +448,10 @@  int ff_decklink_init_device(AVFormatContext *avctx, const char* name)
     IDeckLink *dl = NULL;
     int64_t maxAudioChannels;
     IDeckLinkIterator *iter = CreateDeckLinkIteratorInstance();
+
+    av_log(avctx, AV_LOG_VERBOSE, "Using BlackMagic SDK version %s\n",
+           BLACKMAGIC_DECKLINK_API_VERSION_STRING);
+
     if (!iter) {
         av_log(avctx, AV_LOG_ERROR, "Could not create DeckLink iterator\n");
         return AVERROR_EXTERNAL;