[FFmpeg-devel] configure: The eac3_core bsf needs the ac3 parser

Submitted by Carl Eugen Hoyos on June 12, 2018, 8:04 a.m.

Details

Message ID CAB0OVGrOTb8XvqNxKzFatk3_S-fo8LwnvJazxOxF=hffO0_f9A@mail.gmail.com
State Accepted
Headers show

Commit Message

Carl Eugen Hoyos June 12, 2018, 8:04 a.m.
Hi!

Attached patch fixes a linking error reported on libav-user, other
solutions are slightly more intrusive.

Please comment, Carl Eugen

Comments

Carl Eugen Hoyos June 13, 2018, 10:11 a.m.
2018-06-12 10:04 GMT+02:00, Carl Eugen Hoyos <ceffmpeg@gmail.com>:

> Attached patch fixes a linking error reported on libav-user, other
> solutions are slightly more intrusive.

Patch applied.

Carl Eugen

Patch hide | download patch | download mbox

From d65eb39bb0fb52ca2ba88445535a23aa5fca6b27 Mon Sep 17 00:00:00 2001
From: Carl Eugen Hoyos <ceffmpeg@gmail.com>
Date: Tue, 12 Jun 2018 10:02:44 +0200
Subject: [PATCH] configure: The eac3_core bitstream filter needs the ac3
 parser.

---
 configure |    1 +
 1 file changed, 1 insertion(+)

diff --git a/configure b/configure
index 473be31..994d800 100755
--- a/configure
+++ b/configure
@@ -2992,6 +2992,7 @@  vc1_parser_select="vc1dsp"
 
 # bitstream_filters
 aac_adtstoasc_bsf_select="adts_header"
+eac3_core_bsf_select="ac3_parser"
 filter_units_bsf_select="cbs"
 h264_metadata_bsf_deps="const_nan"
 h264_metadata_bsf_select="cbs_h264"
-- 
1.7.10.4