diff mbox

[FFmpeg-devel] hwcontext: fix comments for av_hwdevice_ctx_alloc()

Message ID 640d9557-3168-9960-a4ed-594010f69c18@gmail.com
State Superseded
Headers show

Commit Message

Jun Zhao March 19, 2017, 7:53 a.m. UTC
From 74fa715cdc1e17ab3a59a9e3efa6ef142dd35d1a Mon Sep 17 00:00:00 2001
From: Jun Zhao <jun.zhao@intel.com>
Date: Sun, 19 Mar 2017 15:44:46 +0800
Subject: [PATCH] hwcontext: fix comments for av_hwdevice_ctx_alloc()

fix the wrong comments for av_hwdevice_ctx_alloc()

Signed-off-by: Jun Zhao <jun.zhao@intel.com>
---
 libavutil/hwcontext.h | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Mark Thompson March 20, 2017, 11:59 p.m. UTC | #1
On 19/03/17 07:53, Jun Zhao wrote:
> From 74fa715cdc1e17ab3a59a9e3efa6ef142dd35d1a Mon Sep 17 00:00:00 2001
> From: Jun Zhao <jun.zhao@intel.com>
> Date: Sun, 19 Mar 2017 15:44:46 +0800
> Subject: [PATCH] hwcontext: fix comments for av_hwdevice_ctx_alloc()
> 
> fix the wrong comments for av_hwdevice_ctx_alloc()
> 
> Signed-off-by: Jun Zhao <jun.zhao@intel.com>
> ---
>  libavutil/hwcontext.h | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/libavutil/hwcontext.h b/libavutil/hwcontext.h
> index 785da09..938c2e4 100644
> --- a/libavutil/hwcontext.h
> +++ b/libavutil/hwcontext.h
> @@ -225,8 +225,7 @@ typedef struct AVHWFramesContext {
>  /**
>   * Allocate an AVHWDeviceContext for a given pixel format.
>   *
> - * @param format a hwaccel pixel format (AV_PIX_FMT_FLAG_HWACCEL must be set
> - *               on the corresponding format descriptor)
> + * @param type the type of the hwaccel device.

Right, good catch that this was wrong.

On the replacement, I dislike the use of the word "hwaccel" here because of confusion with AVHWAccel - this is just the device, and whether it is used for decoder acceleration or something else isn't defined.  (It's slightly unfortunate that the pixdesc flag is AV_PIX_FMT_FLAG_HWACCEL - something like HW_OPAQUE would be a much clearer name.)

How about:

"the type of the hardware device to allocate"

?

Thanks,

- Mark
Jun Zhao March 22, 2017, 12:39 a.m. UTC | #2
On 2017/3/21 7:59, Mark Thompson wrote:
> On 19/03/17 07:53, Jun Zhao wrote:
>> From 74fa715cdc1e17ab3a59a9e3efa6ef142dd35d1a Mon Sep 17 00:00:00 2001
>> From: Jun Zhao <jun.zhao@intel.com>
>> Date: Sun, 19 Mar 2017 15:44:46 +0800
>> Subject: [PATCH] hwcontext: fix comments for av_hwdevice_ctx_alloc()
>>
>> fix the wrong comments for av_hwdevice_ctx_alloc()
>>
>> Signed-off-by: Jun Zhao <jun.zhao@intel.com>
>> ---
>>  libavutil/hwcontext.h | 3 +--
>>  1 file changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/libavutil/hwcontext.h b/libavutil/hwcontext.h
>> index 785da09..938c2e4 100644
>> --- a/libavutil/hwcontext.h
>> +++ b/libavutil/hwcontext.h
>> @@ -225,8 +225,7 @@ typedef struct AVHWFramesContext {
>>  /**
>>   * Allocate an AVHWDeviceContext for a given pixel format.
>>   *
>> - * @param format a hwaccel pixel format (AV_PIX_FMT_FLAG_HWACCEL must be set
>> - *               on the corresponding format descriptor)
>> + * @param type the type of the hwaccel device.
> 
> Right, good catch that this was wrong.
> 
> On the replacement, I dislike the use of the word "hwaccel" here because of confusion with AVHWAccel - this is just the device, and whether it is used for decoder acceleration or something else isn't defined.  (It's slightly unfortunate that the pixdesc flag is AV_PIX_FMT_FLAG_HWACCEL - something like HW_OPAQUE would be a much clearer name.)
> 
> How about:
> 
> "the type of the hardware device to allocate"
> 
> ?

I think it's more accuracy, will submit V2. Thanks

> 
> Thanks,
> 
> - Mark
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel@ffmpeg.org
> http://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
diff mbox

Patch

diff --git a/libavutil/hwcontext.h b/libavutil/hwcontext.h
index 785da09..938c2e4 100644
--- a/libavutil/hwcontext.h
+++ b/libavutil/hwcontext.h
@@ -225,8 +225,7 @@  typedef struct AVHWFramesContext {
 /**
  * Allocate an AVHWDeviceContext for a given pixel format.
  *
- * @param format a hwaccel pixel format (AV_PIX_FMT_FLAG_HWACCEL must be set
- *               on the corresponding format descriptor)
+ * @param type the type of the hwaccel device.
  * @return a reference to the newly created AVHWDeviceContext on success or NULL
  *         on failure.
  */