diff mbox series

[FFmpeg-devel,2/2] configure: Use no-narrowing for cuda_llvm compilation.

Message ID CAHVN4miUvo8cFu3_j5eavqWxRCxbpHsvX5=7du2aMiHc5sPMAw@mail.gmail.com
State New
Headers show
Series [FFmpeg-devel,1/2] cuda_runtime.h: Correct ushort4 to use ushort.
Related show

Checks

Context Check Description
andriy/configure warning Failed to apply patch
andriy/configure warning Failed to apply patch

Commit Message

Matt Oliver Feb. 12, 2021, 3:59 p.m. UTC
This fixes llvm compiler generating errors about narrowing conversion with
recent releases.
---
 configure | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Timo Rothenpieler Feb. 22, 2021, 4:06 p.m. UTC | #1
Both your patches are mangled and do not apply.
Please use git send-email to send raw patches, or attach them as a file.

I manually applied them now, but in the future please make sure your 
patches don't get mangled.
diff mbox series

Patch

diff --git a/configure b/configure
index df298b4b9b..e716f6f932 100755
--- a/configure
+++ b/configure
@@ -6242,7 +6242,7 @@  fi
 if enabled cuda_nvcc; then
     nvccflags="$nvccflags -ptx"
 else
-    nvccflags="$nvccflags -S -nocudalib -nocudainc --cuda-device-only
-include ${source_link}/compat/cuda/cuda_runtime.h"
+    nvccflags="$nvccflags -S -nocudalib -nocudainc --cuda-device-only
-Wno-c++11-narrowing -include ${source_link}/compat/cuda/cuda_runtime.h"
     check_nvcc cuda_llvm
 fi