mbox series

[FFmpeg-devel,v2,0/4] add bdof to the vvc decoder

Message ID TYSPR06MB64333B4BDBC35631D86C61D7AA8D2@TYSPR06MB6433.apcprd06.prod.outlook.com
Headers show
Series add bdof to the vvc decoder | expand

Message

Nuo Mi Aug. 20, 2024, 1:22 p.m. UTC
Major changes since v1:
remove hadd and pmulld as James suggested
reduce vextracti128

Nuo Mi (4):
  avcodec/vvcdec: misc, rename BDOF_BLOCK_SIZE to BDOF_MIN_BLOCK_SIZE
  avcodec/vvcdec: bdof, do not pad sources and gradients to simplify the
    code
  x86/vvcdec: inter, add optical flow avx2 code
  checkasm: add vvc_bdof test

 libavcodec/vvc/dsp.c             |  27 +--
 libavcodec/vvc/dsp.h             |   4 +-
 libavcodec/vvc/inter_template.c  |  75 +++---
 libavcodec/x86/vvc/Makefile      |   1 +
 libavcodec/x86/vvc/vvc_of.asm    | 385 +++++++++++++++++++++++++++++++
 libavcodec/x86/vvc/vvcdsp_init.c |  21 ++
 tests/checkasm/vvc_mc.c          |  50 ++++
 7 files changed, 494 insertions(+), 69 deletions(-)
 create mode 100644 libavcodec/x86/vvc/vvc_of.asm

--
2.34.1

Comments

Nuo Mi Aug. 25, 2024, 2:34 p.m. UTC | #1
On Tue, Aug 20, 2024 at 9:22 PM Nuo Mi <nuomi2021@gmail.com> wrote:

> Major changes since v1:
> remove hadd and pmulld as James suggested
> reduce vextracti128
>
> I'll plan to merge next week to stay on track for the next release, unless
there are any objections
Thank you.

> Nuo Mi (4):
>   avcodec/vvcdec: misc, rename BDOF_BLOCK_SIZE to BDOF_MIN_BLOCK_SIZE
>   avcodec/vvcdec: bdof, do not pad sources and gradients to simplify the
>     code
>   x86/vvcdec: inter, add optical flow avx2 code
>   checkasm: add vvc_bdof test
>


thank you.

>  libavcodec/vvc/dsp.c             |  27 +--
>  libavcodec/vvc/dsp.h             |   4 +-
>  libavcodec/vvc/inter_template.c  |  75 +++---
>  libavcodec/x86/vvc/Makefile      |   1 +
>  libavcodec/x86/vvc/vvc_of.asm    | 385 +++++++++++++++++++++++++++++++
>  libavcodec/x86/vvc/vvcdsp_init.c |  21 ++
>  tests/checkasm/vvc_mc.c          |  50 ++++
>  7 files changed, 494 insertions(+), 69 deletions(-)
>  create mode 100644 libavcodec/x86/vvc/vvc_of.asm
>
> --
> 2.34.1
>
>
Nuo Mi Aug. 31, 2024, 6:14 a.m. UTC | #2
On Sun, Aug 25, 2024 at 10:34 PM Nuo Mi <nuomi2021@gmail.com> wrote:

>
>
> On Tue, Aug 20, 2024 at 9:22 PM Nuo Mi <nuomi2021@gmail.com> wrote:
>
>> Major changes since v1:
>> remove hadd and pmulld as James suggested
>> reduce vextracti128
>>
>> I'll plan to merge next week to stay on track for the next release,
> unless there are any objections
>
Done.
Thanks, James, for the review.

> Thank you.
>
>> Nuo Mi (4):
>>   avcodec/vvcdec: misc, rename BDOF_BLOCK_SIZE to BDOF_MIN_BLOCK_SIZE
>>   avcodec/vvcdec: bdof, do not pad sources and gradients to simplify the
>>     code
>>   x86/vvcdec: inter, add optical flow avx2 code
>>   checkasm: add vvc_bdof test
>>
>
>
> thank you.
>
>>  libavcodec/vvc/dsp.c             |  27 +--
>>  libavcodec/vvc/dsp.h             |   4 +-
>>  libavcodec/vvc/inter_template.c  |  75 +++---
>>  libavcodec/x86/vvc/Makefile      |   1 +
>>  libavcodec/x86/vvc/vvc_of.asm    | 385 +++++++++++++++++++++++++++++++
>>  libavcodec/x86/vvc/vvcdsp_init.c |  21 ++
>>  tests/checkasm/vvc_mc.c          |  50 ++++
>>  7 files changed, 494 insertions(+), 69 deletions(-)
>>  create mode 100644 libavcodec/x86/vvc/vvc_of.asm
>>
>> --
>> 2.34.1
>>
>>