diff mbox series

[FFmpeg-devel] configure: allow OpenSSL>=3.0.0 with GPL

Message ID 20200609001340.52369-1-rcombs@rcombs.me
State New
Headers show
Series [FFmpeg-devel] configure: allow OpenSSL>=3.0.0 with GPL
Related show

Checks

Context Check Description
andriy/default pending
andriy/make success Make finished
andriy/make_fate success Make fate finished

Commit Message

Ridley Combs June 9, 2020, 12:13 a.m. UTC
---
 configure | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Carl Eugen Hoyos June 9, 2020, 6:36 a.m. UTC | #1
> Am 09.06.2020 um 02:13 schrieb rcombs <rcombs@rcombs.me>:
> 
> @@ -1820,6 +1819,7 @@ EXTERNAL_LIBRARY_LIST="
>     mediacodec
>     openal
>     opengl
> +    openssl

(Since a release is discussed)

The patch is not ok and should not be pushed as-is, openSSL 3.0 is not compatible with the GPL 2.0 afaict.

Carl Eugen
Hendrik Leppkes June 9, 2020, 7:11 a.m. UTC | #2
On Tue, Jun 9, 2020 at 9:05 AM Carl Eugen Hoyos <ceffmpeg@gmail.com> wrote:
>
>
>
> > Am 09.06.2020 um 02:13 schrieb rcombs <rcombs@rcombs.me>:
> >
> > @@ -1820,6 +1819,7 @@ EXTERNAL_LIBRARY_LIST="
> >     mediacodec
> >     openal
> >     opengl
> > +    openssl
>
> (Since a release is discussed)
>
> The patch is not ok and should not be pushed as-is, openSSL 3.0 is not compatible with the GPL 2.0 afaict.
>

This is correct, Apache v2 is only considered compatible with GPLv3,
so that would need to be augmented.

- Hendrik
diff mbox series

Patch

diff --git a/configure b/configure
index 8569a60bf8..cbe8b25001 100755
--- a/configure
+++ b/configure
@@ -1731,7 +1731,6 @@  EXTERNAL_LIBRARY_GPL_LIST="
 EXTERNAL_LIBRARY_NONFREE_LIST="
     decklink
     libfdk_aac
-    openssl
     libtls
 "
 
@@ -1820,6 +1819,7 @@  EXTERNAL_LIBRARY_LIST="
     mediacodec
     openal
     opengl
+    openssl
     pocketsphinx
     vapoursynth
 "
@@ -6469,6 +6469,8 @@  enabled openssl           && { check_pkg_config openssl openssl openssl/ssl.h OP
                                check_lib openssl openssl/ssl.h SSL_library_init -lssl32 -leay32 ||
                                check_lib openssl openssl/ssl.h SSL_library_init -lssl -lcrypto -lws2_32 -lgdi32 ||
                                die "ERROR: openssl not found"; }
+enabled openssl && enabled gpl && ! enabled nonfree && { test_cpp_condition "openssl/opensslv.h" "defined(OPENSSL_VERSION_MAJOR) && OPENSSL_VERSION_MAJOR >= 3" ||
+                                                         die "OpenSSL versions prior to 3.0.0 are incompatible with the gpl and --enable-nonfree is not specified."; }
 enabled pocketsphinx      && require_pkg_config pocketsphinx pocketsphinx pocketsphinx/pocketsphinx.h ps_init
 enabled rkmpp             && { require_pkg_config rkmpp rockchip_mpp  rockchip/rk_mpi.h mpp_create &&
                                require_pkg_config rockchip_mpp "rockchip_mpp >= 1.3.7" rockchip/rk_mpi.h mpp_create &&