diff mbox series

[FFmpeg-devel,1/2] avutil/pixfmt: Add AV_PIX_MAX_PLANES

Message ID 20240208125758.29992-1-michael@niedermayer.cc
State New
Headers show
Series [FFmpeg-devel,1/2] avutil/pixfmt: Add AV_PIX_MAX_PLANES | expand

Checks

Context Check Description
yinshiyou/make_loongarch64 success Make finished
yinshiyou/make_fate_loongarch64 success Make fate finished
andriy/make_x86 success Make finished
andriy/make_fate_x86 success Make fate finished

Commit Message

Michael Niedermayer Feb. 8, 2024, 12:57 p.m. UTC
It seems we do not have a named identifier for the maximum planes of pixel formats

Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
---
 libavutil/pixfmt.h | 2 ++
 1 file changed, 2 insertions(+)

Comments

Anton Khirnov Feb. 16, 2024, 1:39 p.m. UTC | #1
Quoting Michael Niedermayer (2024-02-08 13:57:57)
> It seems we do not have a named identifier for the maximum planes of pixel formats
> 
> Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
> ---
>  libavutil/pixfmt.h | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/libavutil/pixfmt.h b/libavutil/pixfmt.h
> index 9c87571f49e..67422f02d02 100644
> --- a/libavutil/pixfmt.h
> +++ b/libavutil/pixfmt.h
> @@ -32,6 +32,8 @@
>  #define AVPALETTE_SIZE 1024
>  #define AVPALETTE_COUNT 256
>  
> +#define AV_PIX_MAX_PLANES 4

I'd call it AV_VIDEO_MAX_PLANES.

Also, needs doxy,APIchanges, and minor bump.
Michael Niedermayer Feb. 16, 2024, 5:11 p.m. UTC | #2
On Fri, Feb 16, 2024 at 02:39:33PM +0100, Anton Khirnov wrote:
> Quoting Michael Niedermayer (2024-02-08 13:57:57)
> > It seems we do not have a named identifier for the maximum planes of pixel formats
> > 
> > Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
> > ---
> >  libavutil/pixfmt.h | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/libavutil/pixfmt.h b/libavutil/pixfmt.h
> > index 9c87571f49e..67422f02d02 100644
> > --- a/libavutil/pixfmt.h
> > +++ b/libavutil/pixfmt.h
> > @@ -32,6 +32,8 @@
> >  #define AVPALETTE_SIZE 1024
> >  #define AVPALETTE_COUNT 256
> >  
> > +#define AV_PIX_MAX_PLANES 4
> 
> I'd call it AV_VIDEO_MAX_PLANES.
> 
> Also, needs doxy,APIchanges, and minor bump.

ok, will apply with all that

[...]

thx
diff mbox series

Patch

diff --git a/libavutil/pixfmt.h b/libavutil/pixfmt.h
index 9c87571f49e..67422f02d02 100644
--- a/libavutil/pixfmt.h
+++ b/libavutil/pixfmt.h
@@ -32,6 +32,8 @@ 
 #define AVPALETTE_SIZE 1024
 #define AVPALETTE_COUNT 256
 
+#define AV_PIX_MAX_PLANES 4
+
 /**
  * Pixel format.
  *