diff mbox series

[FFmpeg-devel,1/2] avutil/channel_layout: add a helper function to get the ambisonic order of a layout

Message ID 20240515010829.2667-1-jamrial@gmail.com
State New
Headers show
Series [FFmpeg-devel,1/2] avutil/channel_layout: add a helper function to get the ambisonic order of a layout | expand

Checks

Context Check Description
andriy/make_x86 success Make finished
andriy/make_fate_x86 success Make fate finished

Commit Message

James Almer May 15, 2024, 1:08 a.m. UTC
Signed-off-by: James Almer <jamrial@gmail.com>
---
 libavutil/channel_layout.c | 17 ++++++++---------
 libavutil/channel_layout.h | 10 ++++++++++
 2 files changed, 18 insertions(+), 9 deletions(-)

Comments

Anton Khirnov May 23, 2024, 7:11 a.m. UTC | #1
Quoting James Almer (2024-05-15 03:08:28)
> Signed-off-by: James Almer <jamrial@gmail.com>
> ---
>  libavutil/channel_layout.c | 17 ++++++++---------
>  libavutil/channel_layout.h | 10 ++++++++++
>  2 files changed, 18 insertions(+), 9 deletions(-)
> 
> diff --git a/libavutil/channel_layout.c b/libavutil/channel_layout.c
> index fd6718e0e7..e213f68666 100644
> --- a/libavutil/channel_layout.c
> +++ b/libavutil/channel_layout.c
> @@ -473,15 +473,14 @@ static int has_channel_names(const AVChannelLayout *channel_layout)
>      return 0;
>  }
>  
> -/**
> - * If the layout is n-th order standard-order ambisonic, with optional
> - * extra non-diegetic channels at the end, return the order.
> - * Return a negative error code otherwise.
> - */
> -static int ambisonic_order(const AVChannelLayout *channel_layout)
> +int av_channel_layout_get_ambisonic_order(const AVChannelLayout *channel_layout)

IMO the _get_ in the name is just making it unnecessarily longer.
James Almer May 23, 2024, 11:55 a.m. UTC | #2
On 5/23/2024 4:11 AM, Anton Khirnov wrote:
> Quoting James Almer (2024-05-15 03:08:28)
>> Signed-off-by: James Almer <jamrial@gmail.com>
>> ---
>>   libavutil/channel_layout.c | 17 ++++++++---------
>>   libavutil/channel_layout.h | 10 ++++++++++
>>   2 files changed, 18 insertions(+), 9 deletions(-)
>>
>> diff --git a/libavutil/channel_layout.c b/libavutil/channel_layout.c
>> index fd6718e0e7..e213f68666 100644
>> --- a/libavutil/channel_layout.c
>> +++ b/libavutil/channel_layout.c
>> @@ -473,15 +473,14 @@ static int has_channel_names(const AVChannelLayout *channel_layout)
>>       return 0;
>>   }
>>   
>> -/**
>> - * If the layout is n-th order standard-order ambisonic, with optional
>> - * extra non-diegetic channels at the end, return the order.
>> - * Return a negative error code otherwise.
>> - */
>> -static int ambisonic_order(const AVChannelLayout *channel_layout)
>> +int av_channel_layout_get_ambisonic_order(const AVChannelLayout *channel_layout)
> 
> IMO the _get_ in the name is just making it unnecessarily longer.

Ok, will remove it.
diff mbox series

Patch

diff --git a/libavutil/channel_layout.c b/libavutil/channel_layout.c
index fd6718e0e7..e213f68666 100644
--- a/libavutil/channel_layout.c
+++ b/libavutil/channel_layout.c
@@ -473,15 +473,14 @@  static int has_channel_names(const AVChannelLayout *channel_layout)
     return 0;
 }
 
-/**
- * If the layout is n-th order standard-order ambisonic, with optional
- * extra non-diegetic channels at the end, return the order.
- * Return a negative error code otherwise.
- */
-static int ambisonic_order(const AVChannelLayout *channel_layout)
+int av_channel_layout_get_ambisonic_order(const AVChannelLayout *channel_layout)
 {
     int i, highest_ambi, order;
 
+    if (channel_layout->order != AV_CHANNEL_ORDER_AMBISONIC &&
+        channel_layout->order != AV_CHANNEL_ORDER_CUSTOM)
+        return AVERROR(EINVAL);
+
     highest_ambi = -1;
     if (channel_layout->order == AV_CHANNEL_ORDER_AMBISONIC)
         highest_ambi = channel_layout->nb_channels - av_popcount64(channel_layout->u.mask) - 1;
@@ -536,7 +535,7 @@  static enum AVChannelOrder canonical_order(AVChannelLayout *channel_layout)
     if (masked_description(channel_layout, 0) > 0)
         return AV_CHANNEL_ORDER_NATIVE;
 
-    order = ambisonic_order(channel_layout);
+    order = av_channel_layout_get_ambisonic_order(channel_layout);
     if (order >= 0 && masked_description(channel_layout, (order + 1) * (order + 1)) >= 0)
         return AV_CHANNEL_ORDER_AMBISONIC;
 
@@ -551,7 +550,7 @@  static enum AVChannelOrder canonical_order(AVChannelLayout *channel_layout)
 static int try_describe_ambisonic(AVBPrint *bp, const AVChannelLayout *channel_layout)
 {
     int nb_ambi_channels;
-    int order = ambisonic_order(channel_layout);
+    int order = av_channel_layout_get_ambisonic_order(channel_layout);
     if (order < 0)
         return order;
 
@@ -945,7 +944,7 @@  int av_channel_layout_retype(AVChannelLayout *channel_layout, enum AVChannelOrde
         if (channel_layout->order == AV_CHANNEL_ORDER_CUSTOM) {
             int64_t mask;
             int nb_channels = channel_layout->nb_channels;
-            int order = ambisonic_order(channel_layout);
+            int order = av_channel_layout_get_ambisonic_order(channel_layout);
             if (order < 0)
                 return AVERROR(ENOSYS);
             mask = masked_description(channel_layout, (order + 1) * (order + 1));
diff --git a/libavutil/channel_layout.h b/libavutil/channel_layout.h
index 8a078d1601..c2ab236488 100644
--- a/libavutil/channel_layout.h
+++ b/libavutil/channel_layout.h
@@ -679,6 +679,16 @@  int av_channel_layout_check(const AVChannelLayout *channel_layout);
  */
 int av_channel_layout_compare(const AVChannelLayout *chl, const AVChannelLayout *chl1);
 
+/**
+ * Return the order if the layout is n-th order standard-order ambisonic.
+ * The presence of optional extra non-diegetic channels at the end is not taken
+ * into account.
+ *
+ * @param channel_layout input channel layout
+ * @return the order of the layout, a negative error code otherwise.
+ */
+int av_channel_layout_get_ambisonic_order(const AVChannelLayout *channel_layout);
+
 /**
  * The conversion must be lossless.
  */