diff mbox series

[FFmpeg-devel,v2] avutil/imgutils: av_image_check_size2() ensure width and height fit in 32bit

Message ID 20240710154956.3225816-1-michael@niedermayer.cc
State New
Headers show
Series [FFmpeg-devel,v2] avutil/imgutils: av_image_check_size2() ensure width and height fit in 32bit | expand

Checks

Context Check Description
andriy/make_x86 success Make finished
andriy/make_fate_x86 success Make fate finished

Commit Message

Michael Niedermayer July 10, 2024, 3:49 p.m. UTC
width and height > 32bit is not supported and its easier to check in a central place

Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
---
 libavutil/imgutils.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

James Almer July 10, 2024, 3:52 p.m. UTC | #1
On 7/10/2024 12:49 PM, Michael Niedermayer wrote:
> width and height > 32bit is not supported and its easier to check in a central place
> 
> Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
> ---
>   libavutil/imgutils.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/libavutil/imgutils.c b/libavutil/imgutils.c
> index d2463815637..b738cff37c2 100644
> --- a/libavutil/imgutils.c
> +++ b/libavutil/imgutils.c
> @@ -298,7 +298,7 @@ int av_image_check_size2(unsigned int w, unsigned int h, int64_t max_pixels, enu
>           stride = 8LL*w;
>       stride += 128*8;
>   
> -    if ((int)w<=0 || (int)h<=0 || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {
> +    if (w==0 || h==0 || w > INT32_MAX || h > INT32_MAX || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {

You could do stride*(h+128ULL) while at it, to make the line more readable.

>           av_log(&imgutils, AV_LOG_ERROR, "Picture size %ux%u is invalid\n", w, h);
>           return AVERROR(EINVAL);
>       }
Michael Niedermayer July 12, 2024, 8:01 p.m. UTC | #2
On Wed, Jul 10, 2024 at 12:52:39PM -0300, James Almer wrote:
> On 7/10/2024 12:49 PM, Michael Niedermayer wrote:
> > width and height > 32bit is not supported and its easier to check in a central place
> > 
> > Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
> > ---
> >   libavutil/imgutils.c | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/libavutil/imgutils.c b/libavutil/imgutils.c
> > index d2463815637..b738cff37c2 100644
> > --- a/libavutil/imgutils.c
> > +++ b/libavutil/imgutils.c
> > @@ -298,7 +298,7 @@ int av_image_check_size2(unsigned int w, unsigned int h, int64_t max_pixels, enu
> >           stride = 8LL*w;
> >       stride += 128*8;
> > -    if ((int)w<=0 || (int)h<=0 || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {
> > +    if (w==0 || h==0 || w > INT32_MAX || h > INT32_MAX || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {
> 
> You could do stride*(h+128ULL) while at it, to make the line more readable.

will apply with this change

thx

[...]
diff mbox series

Patch

diff --git a/libavutil/imgutils.c b/libavutil/imgutils.c
index d2463815637..b738cff37c2 100644
--- a/libavutil/imgutils.c
+++ b/libavutil/imgutils.c
@@ -298,7 +298,7 @@  int av_image_check_size2(unsigned int w, unsigned int h, int64_t max_pixels, enu
         stride = 8LL*w;
     stride += 128*8;
 
-    if ((int)w<=0 || (int)h<=0 || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {
+    if (w==0 || h==0 || w > INT32_MAX || h > INT32_MAX || stride >= INT_MAX || stride*(uint64_t)(h+128) >= INT_MAX) {
         av_log(&imgutils, AV_LOG_ERROR, "Picture size %ux%u is invalid\n", w, h);
         return AVERROR(EINVAL);
     }