diff mbox

[FFmpeg-devel] configure: remove libtls fallback check

Message ID DB3PR0202MB345236E6CE357ABE6F805992EC0F0@DB3PR0202MB3452.eurprd02.prod.outlook.com
State New
Headers show

Commit Message

Stefan _ Dec. 19, 2017, 5:51 p.m. UTC
On 19.12.2017 at 18:28 James Almer wrote:
> On 12/19/2017 2:13 PM, Stefan _ wrote:

>> Last patch had a minor issue, fixed version attached.

> Applied.

Thanks.
>

> The fallback check for that matter should be removed. It's pointless

> since every supported version of the library ships a .pc file, and it's

> pretty much guaranteed to not work with static builds.


Sounds reasonable, corresponding patch is attached.

Comments

James Almer Dec. 19, 2017, 6:14 p.m. UTC | #1
On 12/19/2017 2:51 PM, Stefan _ wrote:
> On 19.12.2017 at 18:28 James Almer wrote:
>> On 12/19/2017 2:13 PM, Stefan _ wrote:
>>> Last patch had a minor issue, fixed version attached.
>> Applied.
> Thanks.
>>
>> The fallback check for that matter should be removed. It's pointless
>> since every supported version of the library ships a .pc file, and it's
>> pretty much guaranteed to not work with static builds.
> 
> Sounds reasonable, corresponding patch is attached.

Applied, thanks.
diff mbox

Patch

From 0224270196ea9329dada21b86848a899c995cc74 Mon Sep 17 00:00:00 2001
From: sfan5 <sfan5@live.de>
Date: Tue, 19 Dec 2017 18:45:27 +0100
Subject: [PATCH] configure: remove libtls fallback check

This check is not needed for any supported version of libtls
and causes issues with static builds (libtls links to -lssl -lcrypto).

Signed-off-by: sfan5 <sfan5@live.de>
---
 configure | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/configure b/configure
index c01f414f9a..1b07dc2ce7 100755
--- a/configure
+++ b/configure
@@ -5894,8 +5894,7 @@  enabled libssh            && require_pkg_config libssh libssh libssh/sftp.h sftp
 enabled libspeex          && require_pkg_config libspeex speex speex/speex.h speex_decoder_init
 enabled libtesseract      && require_pkg_config libtesseract tesseract tesseract/capi.h TessBaseAPICreate
 enabled libtheora         && require libtheora theora/theoraenc.h th_info_init -ltheoraenc -ltheoradec -logg
-enabled libtls            && { check_pkg_config libtls libtls tls.h tls_configure ||
-                               require libtls tls.h tls_configure -ltls; }
+enabled libtls            && require_pkg_config libtls libtls tls.h tls_configure
 enabled libtwolame        && require libtwolame twolame.h twolame_init -ltwolame &&
                              { check_lib libtwolame twolame.h twolame_encode_buffer_float32_interleaved -ltwolame ||
                                die "ERROR: libtwolame must be installed and version must be >= 0.3.10"; }
-- 
2.15.1